QTranslate – Error with PHP 7.1

After updating php to version 7.1, and wordpress 5.0 or newer, qTranslate plugin generate error on pages.

To correct we have to modify file /wp-content/plugins/qtranslate-x/qtranslate_frontend.php

at lines 523 and 597 you must delete “&” from function

function qtranxf_postsFilter($posts,&$query) wrong

function qtranxf_postsFilter($posts,$query) correct

function qtranxf_excludeUntranslatedPosts($where,&$query) wrong

function qtranxf_excludeUntranslatedPosts($where,$query) correct